This server has been deleted from the list and is available only for archival purposes.
chevron_left Back to List



Corrupted-V is a Pixelmon server for 1.8 that's been around for a little while. We always try to have the server up to date with the latest Pixelmon version.

Some things to know before connecting is that this server uses a mod blocker, so anything except the approved mods will be allowed to connect. The only one allowed right now is OptiFine. Keep Inventory is on but the server Difficulty is Normal with Hunger enabled.


There are no reviews for this server yet, you can be the first!